Mailgun - Issues with Login, APIs, and Other Mailgun Functionality

Major incident Web Hosting
2022-06-09 05:25 PDT · 5 hours, 43 minutes

Updates

Resolved

Mailgun is monitoring their fixes.

June 9, 2022 · 11:08 PDT
Issue

Mailgun, the service we use to send emails from our websites, is experiencing a major outage.
https://status.mailgun.com/incidents/gcm3zw1lvfl4

At present, their latest update: “We continue to work on a fix and are experiencing sending delays”

June 9, 2022 · 06:59 PDT

← Back